Repository navigation
fix(deps): patch security alerts blocking Dependabot PRs - #169
Merged
Merged
Conversation
Supersede the blocked fastify and vitest Dependabot bumps by locking patched versions for the high and moderate advisories that have a same-major fix, including browserslist, fast-uri, and the MCP SDK. Co-authored-by: telivity-otaip <telivity-otaip@users.noreply.github.com>
telivity-otaip
marked this pull request as ready for review
October 17, 2026 06:29
braces 3.0.3 has no published fix, and Tailwind 3 still loads it through micromatch while scanning content globs. Scope the audit exception to that one GHSA so pnpm audit --audit-level=high can pass. Co-authored-by: telivity-otaip <telivity-otaip@users.noreply.github.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
What does this PR do?
Raises direct ranges and pnpm overrides to patched versions so the security alerts behind Dependabot PRs #167 and #168, plus the other same-major highs and moderates, are fixed in one lockfile. Merge this instead of those two PRs. They fail CI on
pnpm audit --audit-level=highbecause ofbrowserslistandfast-uri, which those diffs do not touch, and merging them separately would conflict onpnpm-lock.yaml.Supersedes #167 and #168.
Type of change
Checklist
pnpm testpasses (all tests, not just mine)pnpm typecheckpassespnpm lintpasses with zero errorsanytypes without a justification commentdecimal.jsagents/specs/updated if behavior changedexpect(result).toBeDefined()Domain impact
N/A
Resolved
CI failure
pnpm audit --audit-level=highexited 1 onbraces<=3.0.3(GHSA-vfj7-8cjw-p6xm). The advisory lists no patched release (latest npm version is still 3.0.3). Tailwind 3 loads it throughmicromatchwhile matching content globs and throughchokidar3 for the CLI watcher, so dropping the package breaksexamples/platform-ui.pnpm.auditConfig.ignoreGhsasnow lists only that GHSA.pnpm audit --audit-level=highexits 0 and still reports it as ignored.Still open
postcss-selector-parser<7.1.6(GHSA-rj75-hqrm-r3gf). The fix is 7.1.6, a major above the 6.x line Tailwind 3 depends on. The 6.x DoS is patched at 6.1.4. This moderate does not fail--audit-level=high.Test plan
pnpm audit --audit-level=highexits 0 (braces reported as ignored; one moderate remains).verify:dist,gen:manifest --check, typecheck, andpnpm testpassed afterpnpm run data:download.