Repository navigation
ci: test every supported Python version; require Python 3.11+ - #195
Merged
Merged
Conversation
The unit-test matrix was fixed at 3.9 and 3.13, while 3.9 and 3.10 are past end of life and 3.11, 3.12, 3.14 and 3.15 went untested. A first job now reads the supported versions (released, not past EOL) from endoflife.date and feeds them to the matrix, falling back to a fixed list if the API is unreachable. fail-fast is off so one version's failure doesn't cancel the others. The coverage steps were gated on 3.11, which wasn't in the matrix, so coverage never ran; they now run on the oldest supported version. requires-python, the classifiers, the Black/Ruff targets and the docs move to 3.11+ to match what CI tests. Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
The unit-test matrix was fixed at 3.9 and 3.13. Python 3.9 and 3.10 are past end of life, and four supported versions went untested. A first job now reads the supported versions from endoflife.date on every run, so the matrix follows new releases and end-of-life dates without edits.
Coverage was gated on 3.11, which wasn't in the matrix, so it never ran. It now runs on the oldest supported version.
The package now claims only what CI tests:
Black stops at
py314because the Black version pinned in pre-commit (26.1.0) doesn't acceptpy315yet. Black's targets only control which syntax it may use; 3.15 is still tested.installation.mdandcontributing.mdnow say 3.11+.Evidence
After: the job's filter, run against the live API today, returns
["3.11","3.12","3.13","3.14","3.15"]. With the API URL broken, the fallback is used.pre-commit run --all-filespasses, and so do the CI lint job'sruff checkandblack --check. The workflow file is valid YAML.Merge Danger
Door: one-way
Once a release ships with
requires-python = ">=3.11", pip stops offering new RushTI releases to Python 3.9 and 3.10 users. Their existing installs keep working, and the standalone Windows executable isn't affected.Blast Radius: packaging
master, the Build workflow re-uploads the Windows zip on the latest release (v2.3.2); the source is unchanged, so that build is effectively 2.3.2.fail-fast: falsethe other versions still report.[Unreleased]; the second to merge resolves a small conflict.🤖 Generated with Claude Code